読者です 読者をやめる 読者になる 読者になる

のねのBlog

パソコンやソフト開発で起きた問題など書きます。よろしくお願いします。

Programing-Python

pyenv install 3.4.3

$ pyenv install 3.4.3 Downloading Python-3.4.3.tgz... -> https://www.python.org/ftp/python/3.4.3/Python-3.4.3.tgz Installing Python-3.4.3... BUILD FAILED (OS X 10.11.3 using python-build 20150818) Inspect or clean up the working tree at /v…

ttx -t EBDT -z bitwise

$ ttx -t EBDT -z bitwise MS-Gothic.ttf Dumping "MS-Gothic.ttf" to "MS-Gothic#7.ttx"... Dumping 'EBDT' table... Traceback (most recent call last): File "/Users/m_fujii/bin/FDK/Tools/osx/../SharedData/FDKScripts/ttx.py", line 13, in <module> ttx.mai</module>…

ttx -t EBDT -z row

$ ttx -t EBDT -z row MS-Gothic.ttf Dumping "MS-Gothic.ttf" to "MS-Gothic#5.ttx"... Dumping 'EBDT' table... Traceback (most recent call last): File "/Users/m_fujii/bin/FDK/Tools/osx/../SharedData/FDKScripts/ttx.py", line 13, in <module> ttx.main(sy</module>…

PTVS2.2をインストールしようとしたところエラー

Visual Studio Community 2015でPythonの機能を追加するために、PTVS2.2をインストールしたところ、以下のエラーになった。 セットアップがブロックされました。 以下の問題を修正してから、セットアップを再度実行してください。 詳細については、一般的な…

bad char in struct format

bad char in struct format-Data = struct.unpack_from('>4s>H>H>H>H', data, offset) Data = struct.unpack_from('>4sHHHH', data, offset)struct.error: bad char in struct format

unpack requires a bytes object of length 16

struct: unpack Requires String Argument of Length 16

hb-shape --help-all

u01@vm01:~$ hb-shape --help-all Usage: hb-shape [OPTION...] [FONT-FILE] [TEXT]Help Options: -h, --help Show help options --help-all Show all help options --help-font Options controlling the font --help-text Options controlling the input te…

hb-view --help-all

u01@vm01:~$ hb-view --help-all Usage: hb-view [OPTION...] [FONT-FILE] [TEXT]Help Options: -h, --help Show help options --help-all Show all help options --help-font Options controlling the font --help-text Options controlling the input text…

Fatal Python error: Py_Initialize: unable to load the file system codec

>python Fatal Python error: Py_Initialize: unable to load the file system codec File "c:\Python27\\lib\encodings\__init__.py", line 123 raise CodecRegistryError,\ ^ SyntaxError: invalid syntaxPYTHONPATHを消したら動いた。

pacman -Rsc mingw-w64-x86_64-gcc

$ pacman -Rsc mingw-w64-x86_64-gcc 依存関係を確認しています... パッケージ (8) mingw-w64-x86_64-gcc-ada-5.2.0-4 mingw-w64-x86_64-gcc-fortran-5.2.0-4 mingw-w64-x86_64-gcc-objc-5.2.0-4 mingw-w64-x86_64-isl-0.14.1-2 mingw-w64-x86_64-mpc-1.0.3-…

pkg-config

MINGW64 ~/layout/oss/pango-1.38.1 $ pkg-config --list-all isl isl - isl Library gnurx regex - Regular Expressions library formw formw - ncurses 6.0 add-on library menuw menuw - ncurses 6.0 add-on library python2 Python - Python library pan…

.bashrc

export PS1="\w:$ " alias vi=vim export PYTHONHOME=/mingw64 export PYTHONPATH=/mingw64/lib/python2.7:$PYTHONPATH

toolchain

pacman -S mingw-w64-x86_64-toolchain $ pacman -S mingw-w64-x86_64-toolchain :: 16 のパッケージがグループ mingw-w64-x86_64-toolchain にあります: :: リポジトリ mingw64 1) mingw-w64-x86_64-binutils 2) mingw-w64-x86_64-crt-git 3) mingw-w64-x86…

glib-2.46.2 ImportError: No module named pyexpat

Making all in gio make[2]: ディレクトリ '/home/u01/layout/oss/glib-2.46.2/gio' に入ります GEN gconstructor_as_data.h GEN gdbus-daemon-generated.c Traceback (most recent call last): File "./gdbus-2.0/codegen/gdbus-codegen.in", line 37, in <module> </module>…

glib-2.46.2 ./configure --prefix=$HOME/usr

~/layout/oss/glib-2.46.2:$ ./configure --prefix=$HOME/usr

glib-2.46.2 ./configure --help

~/layout/oss/glib-2.46.2:$ ./configure --help

make -n install

~/layout/oss/glib-2.46.2:$ make -n installconfigureのときに、pythonがうまく動いていない。 configure:7329: checking for a Python interpreter with version >= 2.5 configure:7346: python -c import sys # split strings by '.' and convert to nume…

pacman -Q

よく使うコマンドとしては pacman -S <package_name1> [package_name2...] : 指定したパッケージをインストールする pacman -Sl [repository] : パッケージを一覧表示する(リポジトリを指定可能) pacman -Ss [regex...] : パッケージを一覧・検索する(キーワードを指定可</package_name1>…

repoでfatal error Unable to remap

$ ~/bin/repo init -u git://android.git.kernel.org/platform/manifest.git warning: gpg (GnuPG) is not available. warning: Installing it is strongly encouraged. Getting repo ... from git://android.git.kernel.org/tools/repo.git 0 [main] python…