のねのBlog

パソコンの問題や、ソフトウェアの開発で起きた問題など書いていきます。よろしくお願いします^^。

m_fujii@none11:~$ dpkg -l '*docker*'
dpkg-query: no packages found matching *docker*
m_fujii@none11:~$ sudo apt-get install docker-ce=18.06.1~ce~3-0~ubuntu
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
aufs-tools cgroupfs-mount pigz
The following NEW packages will be installed:
aufs-tools cgroupfs-mount docker-ce pigz
0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/40.1 MB of archives.
After this operation, 198 MB of additional disk space will be used.
Do you want to continue? [Y/n]
Selecting previously unselected package pigz.
(Reading database ... 215015 files and directories currently installed.)
Preparing to unpack .../pigz_2.3.1-2_amd64.deb ...
Unpacking pigz (2.3.1-2) ...
Selecting previously unselected package aufs-tools.
Preparing to unpack .../aufs-tools_1%3a3.2+20130722-1.1ubuntu1_amd64.deb ...
Unpacking aufs-tools (1:3.2+20130722-1.1ubuntu1) ...
Selecting previously unselected package cgroupfs-mount.
Preparing to unpack .../cgroupfs-mount_1.2_all.deb ...
Unpacking cgroupfs-mount (1.2) ...
Selecting previously unselected package docker-ce.
Preparing to unpack .../docker-ce_18.06.1~ce~3-0~ubuntu_amd64.deb ...
Unpacking docker-ce (18.06.1~ce~3-0~ubuntu) ...
Processing triggers for man-db (2.7.5-1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for ureadahead (0.100.0-19) ...
Processing triggers for systemd (229-4ubuntu21.4) ...
Setting up pigz (2.3.1-2) ...
Setting up aufs-tools (1:3.2+20130722-1.1ubuntu1) ...
Setting up cgroupfs-mount (1.2) ...
Setting up docker-ce (18.06.1~ce~3-0~ubuntu) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Processing triggers for systemd (229-4ubuntu21.4) ...
Processing triggers for ureadahead (0.100.0-19) ...
m_fujii@none11:~$ dpkg -l '*docker*'
Desired=Unknown/Install/Remove/Purge/Hold

Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
/ Name Version Architecture Description
        • =========================-=================-=================-=======================================================

un docker (no description available)
ii docker-ce 18.06.1~ce~3-0~ub amd64 Docker: the open-source application container engine
un docker-ee (no description available)
un docker-engine (no description available)
un docker-engine-cs (no description available)
un docker.io (no description available)
un lxc-docker (no description available)
un lxc-docker-virtual-packag (no description available)
m_fujii@none11:~$ sudo apt-get install nvidia-docker2
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
libnvidia-container-tools libnvidia-container1 nvidia-container-runtime nvidia-container-runtime-hook
The following NEW packages will be installed:
libnvidia-container-tools libnvidia-container1 nvidia-container-runtime nvidia-container-runtime-hook nvidia-docker2
0 upgraded, 5 newly installed, 0 to remove and 1 not upgraded.
Need to get 2,393 kB of archives.
After this operation, 9,718 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 https://nvidia.github.io/libnvidia-container/ubuntu16.04/amd64 libnvidia-container1 1.0.0~rc.2-1 [56.1 kB]
Get:2 https://nvidia.github.io/libnvidia-container/ubuntu16.04/amd64 libnvidia-container-tools 1.0.0~rc.2-1 [15.0 kB]
Get:3 https://nvidia.github.io/nvidia-container-runtime/ubuntu16.04/amd64 nvidia-container-runtime-hook 1.4.0-1 [575 kB]
Get:4 https://nvidia.github.io/nvidia-container-runtime/ubuntu16.04/amd64 nvidia-container-runtime 2.0.0+docker18.06.1-1 [1,744 kB]
Get:5 https://nvidia.github.io/nvidia-docker/ubuntu16.04/amd64 nvidia-docker2 2.0.3+docker18.06.1-1 [2,894 B]
Fetched 2,393 kB in 1s (1,648 kB/s)
Selecting previously unselected package libnvidia-container1:amd64.
(Reading database ... 215300 files and directories currently installed.)
Preparing to unpack .../libnvidia-container1_1.0.0~rc.2-1_amd64.deb ...
Unpacking libnvidia-container1:amd64 (1.0.0~rc.2-1) ...
Selecting previously unselected package libnvidia-container-tools.
Preparing to unpack .../libnvidia-container-tools_1.0.0~rc.2-1_amd64.deb ...
Unpacking libnvidia-container-tools (1.0.0~rc.2-1) ...
Selecting previously unselected package nvidia-container-runtime-hook.
Preparing to unpack .../nvidia-container-runtime-hook_1.4.0-1_amd64.deb ...
Unpacking nvidia-container-runtime-hook (1.4.0-1) ...
Selecting previously unselected package nvidia-container-runtime.
Preparing to unpack .../nvidia-container-runtime_2.0.0+docker18.06.1-1_amd64.deb ...
Unpacking nvidia-container-runtime (2.0.0+docker18.06.1-1) ...
Selecting previously unselected package nvidia-docker2.
Preparing to unpack .../nvidia-docker2_2.0.3+docker18.06.1-1_all.deb ...
Unpacking nvidia-docker2 (2.0.3+docker18.06.1-1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
Setting up libnvidia-container1:amd64 (1.0.0~rc.2-1) ...
Setting up libnvidia-container-tools (1.0.0~rc.2-1) ...
Setting up nvidia-container-runtime-hook (1.4.0-1) ...
Setting up nvidia-container-runtime (2.0.0+docker18.06.1-1) ...
Setting up nvidia-docker2 (2.0.3+docker18.06.1-1) ...
Processing triggers for libc-bin (2.23-0ubuntu10) ...
m_fujii@none11:~$